Algoritmizálás, adatmodellezés tanítása 2. előadás

Méret: px
Mutatás kezdődik a ... oldaltól:

Download "Algoritmizálás, adatmodellezés tanítása 2. előadás"

Átírás

1 Algoritmizálás, adatmodellezés tanítása 2. előadás

2 Programozási tételek Mi az, hogy programozási tétel? Típusfeladat általános megoldása. Sorozat érték Sorozat sorozat Sorozat sorozatok Sorozatok sorozat

3 7. Másolás - függvényszámítás Feladatok: Egy számsorozat tagjainak adjuk meg az abszolút értékét! Egy szöveget alakítsunk át csupa kisbetűssé! Számoljuk ki két vektor összegét! Készítsünk függvénytáblázatot a sin(x) függvényről!

4 7. Másolás - függvényszámítás Feladatok: Ismerjük N hónap sorszámát, adjuk meg a nevét! Mi bennük a közös? N darab valamihez kell hozzárendelni másik N darab valamit, ami akár az előbbitől különböző típusú is lehet. A darabszám marad, a sorrend is marad

5 7. Másolás - függvényszámítás Bemenet: N: Egész, X: Tömb[1..N: Valami1] Kimenet: Y: Tömb[1..N: Valami2] Előfeltétel: Utófeltétel: i (1 i N): Y[i]=f(X[i]) Másolás: Ciklus i=1-től N-ig Y[i]:=f(X[i]) Ciklus vége Eljárás vége

6 7. Másolás - függvényszámítás Vektorok összege: Bemenet: N: Egész, X,Z: Tömb[1..N: Valós] Kimenet: Y: Tömb[1..N: Valós] Előfeltétel: Utófeltétel: i(1 i N): Y[i]=X[i]+Z[i] Másolás: Ciklus i=1-től N-ig Y[i]:=X[i]+Z[i] Ciklus vége Eljárás vége

7 7. Másolás - függvényszámítás Számok abszolút értéke: Bemenet: N: Egész, X: Tömb[1..N: Valós] Kimenet: Y: Tömb[1..N: Valós] Előfeltétel: Utófeltétel: i(1 i N): Y[i]=abs(X[i]) Másolás: Ciklus i=1-től N-ig Ha X[i] 0 akkor Y[i]:=X[i] különben Y[i]:=-X[i] Ciklus vége Eljárás vége

8 8. Kiválogatás Feladatok: Adjuk meg egy osztály kitűnő tanulóit! Adjuk meg egy természetes szám összes osztóját! Adjuk meg egy mondat magas hangrendű szavait! Adjuk meg emberek egy halmazából a 180 cm felettieket!

9 8. Kiválogatás Feladatok: Adjuk meg egy év azon napjait, amikor délben nem fagyott! Adjuk meg egy szó magánhangzóit! Mi bennük a közös? N darab valami közül kell megadni az összes, adott T tulajdonsággal rendelkezőt!

10 8. Kiválogatás Bemenet: N: Egész, X: Tömb[1..N: Valami] Kimenet: Db: Egész, Y: Tömb[1..N: Egész] Előfeltétel: Utófeltétel: Db T i 1 ( X [ i]) és i(1 i Db): T(X[Y[i]]) és Y (1,2,,N) N

11 8. Kiválogatás Kiválogatás: Db:=0 Ciklus i=1-től N-ig Ha T(X[i]) akkor Db:=Db+1 Y[Db]:=i Ciklus vége Eljárás vége. A sorszám általánosabb, mint az érték. Ha mégis érték kellene, akkor: Y[Db]:=X[i] szerepelne

12 8. Kiválogatás Adjuk meg egy év azon napjait, amikor délben nem fagyott! Bemenet: N: Egész, X: Tömb[1..N: Valós] Kimenet: Db: Egész, Y: Tömb[1..N: Egész] Előfeltétel: Utófeltétel: Db N i 1 1 X [ i] 0 és i(1 i Db): X[Y[i]] 0 és Y (1,2,,N)

13 8. Kiválogatás Kiválogatás: Db:=0 Ciklus i=1-től N-ig Ha X[i] 0 akkor Db:=Db+1 Y[Db]:=i Ciklus vége Eljárás vége

14 10. Szétválogatás Feladatok: Adjuk meg egy osztály kitűnő és nem kitűnő tanulóit! Adjuk meg emberek egy halmazából a 180 cm felettieket és a nem 180 cm felettieket! Adjuk meg egy számsorozatból a páros és a páratlan számokat is!

15 10. Szétválogatás Feladatok: Adjuk meg egy év azon napjait, amikor délben fagyott, illetve nem fagyott! Adjuk meg egy angol szó magán- és mássalhangzóit! Mi bennük a közös? N darab valami közül kell megadni az összes, adott T tulajdonsággal rendelkezőt, illetve nem rendelkezőt!

16 10. Szétválogatás Bemenet: N: Egész, X: Tömb[1..N: Valami] Kimenet: Db: Egész, Y,Z: Tömb[1..N: Egész] Előfeltétel: Utófeltétel: Db T i 1 ( X [ i]) és i(1 i Db): T(X[Y[i]]) és és i(1 i N-Db): nem T(X[Z[i]]) és Y (1,2,,N) és Z (1,2,,N) N

17 10. Szétválogatás Szétválogatás: Db:=0; DbZ:=0 Ciklus i=1-től N-ig Ha T(X[i]) akkor Db:=Db+1 Y[Db]:=i különben DbZ:=DbZ+1 Z[DbZ]:=i Ciklus vége Eljárás vége. Itt is szerepelhetne :=i helyett :=X[i], ha csak az értékekre lenne szükségünk

18 10. Szétválogatás Probléma: Y-ban és Z-ben együtt csak N darab elem van, azaz elég lenne az egyik. Bemenet: N: Egész, X: Tömb[1..N: Valami] Kimenet: Db: Egész, Y: Tömb[1..N: Egész] Előfeltétel: Utófeltétel: Db T i 1 ( X [ i]) és i(1 i Db): T(X[Y[i]]) és és i(db+1 i N): nem T(X[Y[i]]) és Y=permutáció(1,2,,N) N

19 10. Szétválogatás Szétválogatás: Db:=0; DbZ:=N+1 Ciklus i=1-től N-ig Ha T(X[i]) akkor Db:=Db+1 Y[Db]:=i különben DbZ:=DbZ-1 Y[DbZ]:=i Ciklus vége Eljárás vége. A DbZ helyett jobb lenne pl. az IndZ elnevezés

20 11. Metszet Feladatok: Adjuk meg két természetes szám közös osztóit! A télen és a nyáron megfigyelhető madarak alapján adjuk meg a nem költöző madarakat! Két ember szabad órái alapján mondjuk meg, hogy mikor beszélgethetnek egymással!

21 11. Metszet Feladatok: Adjuk meg azokat az állatokat, amelyeket a budapesti és a veszprémi állatkertben is megnézhetünk! Mi bennük a közös? Ismerünk két halmazt (tetszőleges típusú elemekkel), meg kell adnunk azokat az elemeket, amelyek mindkét halmazban szerepelnek!

22 11. Metszet Mit tehetünk a halmazokkal? Eddig a specifikációban használtunk, az algoritmusban és a kódban nem. A halmaz elemeit egy tömbben felsorolhatjuk, de ekkor ügyelni kell arra, hogy minden elem csak egyszer szerepeljen! Fogalom: halmazf(x,n) = i,j (1 i,j N): i j X[i] X[j]

23 11. Metszet Bemenet: N,M: Egész, X: Tömb[1..N: Valami] Y: Tömb[1..M: Valami] Kimenet: Db: Egész, Z: Tömb[1..min(N,M): Valami] Előfeltétel: halmazf(x,n) és halmazf(y,m) Utófeltétel: Db i 1 X [ i] Y és i(1 i Db): Z[i] X és Z[i] Y és halmazf(z,db) N

24 11. Metszet Metszet: Db:=0 Ciklus i=1-től N-ig j:=1 Ciklus amíg j M és X[i] Y[j] j:=j+1 Ciklus vége Ha j M akkor Db:=Db+1 Z[Db]:=X[i] Ciklus vége Eljárás vége

25 11. Metszet A megoldás egy kiválogatás és egy eldöntés. Feladatvariációk: Ismerünk két halmazt, meg kell adnunk a közös elemek számát! Ismerünk két halmazt, meg kell adnunk, hogy van-e közös elemük! Ismerünk két halmazt, meg kell adnunk egy közös elemüket!

26 12. Unió Feladatok: Két szakkör tanulói alapján adjuk meg a szakkörre járókat! A télen és a nyáron megfigyelhető madarak alapján adjuk meg a megfigyelhető madarakat! Két ember szabad órái alapján mondjuk meg, hogy mikor tudjuk elérni valamelyiket!

27 12. Unió Feladatok: Adjuk meg azokat az állatokat, amelyeket a budapesti vagy a veszprémi állatkertben megnézhetünk! Mi bennük a közös? Ismerünk két halmazt (tetszőleges típusú elemekkel), meg kell adnunk azokat az elemeket, amelyek legalább az egyik halmazban szerepelnek!

28 12. Unió Bemenet: N,M: Egész, X: Tömb[1..N: Valami] Y: Tömb[1..M: Valami] Kimenet: Db: Egész, Z: Tömb[1..N+M: Valami] Előfeltétel: halmazf(x,n) és halmazf(y,m) Utófeltétel: Db N j 1 y[ j] X és i(1 i Db): Z[i] X vagy Z[i] Y és halmazf(z,db) M

29 12. Unió Unió: Z:=X; Db:=N Ciklus j=1-től M-ig i:=1 Ciklus amíg i N és X[i] Y[j] i:=i+1 Ciklus vége Ha i>n akkor Db:=Db+1 Z[Db]:=Y[j] Ciklus vége Eljárás vége

30 Programozási tételek Sorozat sorozat 7. Másolás függvényszámítás 8. Kiválogatás 9. Rendezés (később lesz) Sorozat sorozatok 10. Szétválogatás Sorozatok sorozat 11. Metszet 12. Unió

31 Kiválogatás + összegzés Feladat: Adott tulajdonságú elemek összege (feltételes összegzés). Specifikáció: Bemenet: N:Egész, X:Tömb[1..N:Egész] Kimenet: S:Egész Előfeltétel: N 0 N Utófeltétel: S= i 1 T(X[i]) X[i]

32 Kiválogatás + összegzés 1. megoldási ötlet: Válogassuk ki az adott tulajdonságúakat, majd utána adjuk össze őket! Válogatás: Db:=0; S:=0 Ciklus i=1-től N-ig Ha T(X(i)) akkor Db:=Db+1 Y(Db):=i Ciklus vége Ciklus i=1-től Db-ig S:=S+X(Y(i)) Ciklus vége Eljárás vége

33 Kiválogatás + összegzés 2. megoldási ötlet: Kiválogatás helyett azonnal adjuk össze a megfelelő elemeket! nincs elem-/indexfeljegyzés (Y-ban) + nincs számlálás (Dbben) Válogatás: S:=0 Ciklus i=1-től N-ig Ha T(X(i)) akkor S:=S+X(i) Ciklus vége Eljárás vége

34 Kiválogatás + maximumkiválasztás Feladat: Adott tulajdonságú elemek maximuma (feltételes maximumkeresés). Specifikáció: Bemenet: N:Egész, X:Tömb[1..N:Valami] Kimenet: Max:Egész, Van:Logikai Előfeltétel: N 0 Utófeltétel: Van= i (1 i N): T(X[i]) és Van ( 1 Max N és T(X[Max]) és i(1 i N): T(X[i]) X[Max] X[i] )

35 Kiválogatás + maximumkiválasztás 1. megoldási ötlet: Válogassuk ki az adott tulajdonságúakat, majd keressünk maximumot, ha van értelme! Feltételes maximum: Db:=0 Ciklus i=1-től N-ig Ha T(X(i)) akkor Db:=Db+1 Y(Db):=i Ciklus vége Van:=(Db>0)

36 Kiválogatás + maximumkiválasztás 1. megoldási ötlet: Válogassuk ki az adott tulajdonságúakat, majd keressünk maximumot, ha van értelme! Ha Van akkor Max:=Y(1) Ciklus i=2-től Db-ig Ha X(Y(i))>X(Max) akkor Max:=i Ciklus vége Eljárás vége

37 Kiválogatás + maximumkiválasztás 2. megoldási ötlet: Kiválogatás helyett azonnal válasszuk ki a maximumot! Kell egy fiktív 0. elem a maximumkiválasztáshoz, ami kisebb minden normál elemnél. Feltételes maximum: X(0):=- ; Max:=0 Ciklus i=1-től N-ig Ha T(X(i)) és X(i)>X(Max) akkor Max:=i Ciklus vége Van:=(Max>0) Eljárás vége

38 Maximumkiválasztás + kiválogatás Feladat: Összes maximális elem kiválogatása. Specifikáció: Bemenet: N:Egész, X:Tömb[1..N:Valami] Kimenet: Db:Egész, Max:Tömb[1..Db:Egész] Előfeltétel: N>0 Utófeltétel: Db = N 1 i X[i] X[Max[1]] 1 és i(1 i Db): j(1 j N): X[Max[i]] X[j] és Max (1,2,,N)

39 Maximumkiválasztás + kiválogatás 1. megoldási ötlet: Határozzuk meg a maximumot, majd válogassuk ki a vele egyenlőket! Maximumkiválogatás: Maxért:=X(1) Ciklus i=2-től N-ig Ha X(i)>Maxért akkor Maxért:=X(i) Ciklus vége

40 Maximumkiválasztás + kiválogatás 1. megoldási ötlet: Határozzuk meg a maximumot, majd válogassuk ki a vele egyenlőket! Db:=0 Ciklus i=1-től N-ig Ha X(i)=Maxért akkor Db:=Db+1; Max(Db):=i Ciklus vége Eljárás vége

41 Maximumkiválasztás + kiválogatás 2. megoldási ötlet: A pillanatnyi maximálissal egyenlőket azonnal válogassuk ki! Maximumkiválogatás: Db:=1; Max(1):=1; Maxért:=X(1) Ciklus i=2-től N-ig Ha X(i)>Maxért akkor Db:=1; Max(1):=i; Maxért:=X(i) különben ha X(i)=Maxért akkor Db:=Db+1; Max(Db):=i Ciklus vége Eljárás vége

42 Eldöntés + megszámolás Feladat: Van-e egy sorozatban K darab adott tulajdonságú elem? Specifikáció: Bemenet: N,K:Egész, X:Tömb[1..N:Valami] Kimenet: Van:Logikai Előfeltétel: N 0 [és K>0] Utófeltétel: db= N 1 i 1 T(X[i]) és Van=db K

43 Eldöntés + megszámolás 1. megoldási ötlet: Számoljuk meg, hogy hány adott tulajdonságú van, majd nézzük meg, hogy ez legalább K-e! (Azaz valójában nincs: eldöntés tétel!) Eldönt és megszámol: Db:=0 Ciklus i=1-től N-ig Ha T(X(i)) akkor Db:=Db+1 Ciklus vége Van:=(Db K) Eljárás vége

44 Eldöntés + megszámolás 2. megoldási ötlet: Ha már találtunk K darab adott tulajdonságút, akkor ne nézzük tovább! Eldönt és megszámol: Db:=0; i:=1 Ciklus amíg i N és Db<K Ha T(X(i)) akkor Db:=Db+1 i:=i+1 Ciklus vége Van:=(Db=K) Eljárás vége

45 Algoritmizálás, adatmodellezés tanítása 2. előadás vége

Algoritmizálás, adatmodellezés tanítása 1. előadás

Algoritmizálás, adatmodellezés tanítása 1. előadás Algoritmizálás, adatmodellezés 1. előadás Az algoritmus fogalma végrehajtható (van hozzá végre-hajtó) lépésenként hajtható végre a lépések maguk is algoritmusok pontosan definiált, adott végre-hajtási

Részletesebben

Bánsághi Anna 2014 Bánsághi Anna 1 of 68

Bánsághi Anna 2014 Bánsághi Anna 1 of 68 IMPERATÍV PROGRAMOZÁS Bánsághi Anna anna.bansaghi@mamikon.net 3. ELŐADÁS - PROGRAMOZÁSI TÉTELEK 2014 Bánsághi Anna 1 of 68 TEMATIKA I. ALAPFOGALMAK, TUDOMÁNYTÖRTÉNET II. IMPERATÍV PROGRAMOZÁS Imperatív

Részletesebben

Összetett programozási tételek

Összetett programozási tételek Összetett programozási tételek 3. előadás Sergyán Szabolcs sergyan.szabolcs@nik.uni-obuda.hu Óbudai Egyetem Neumann János Informatikai Kar 2011. szeptember 19. Sergyán (OE NIK) AAO 03 2011. szeptember

Részletesebben

Programozási tételek. Dr. Iványi Péter

Programozási tételek. Dr. Iványi Péter Programozási tételek Dr. Iványi Péter 1 Programozási tételek A programozási tételek olyan általános algoritmusok, melyekkel programozás során gyakran találkozunk. Az algoritmusok általában számsorozatokkal,

Részletesebben

Pásztor Attila. Algoritmizálás és programozás tankönyv az emeltszintű érettségihez

Pásztor Attila. Algoritmizálás és programozás tankönyv az emeltszintű érettségihez Pásztor Attila Algoritmizálás és programozás tankönyv az emeltszintű érettségihez 9. ÖSSZETETT FELADATOK...111 9.1. ELEMI ALGORITMUSOK ÖSSZEÉPÍTÉSE...111 9.2. ÖSSZEFOGLALÁS...118 9.3. GYAKORLÓ FELADATOK...118

Részletesebben

Informatikai tehetséggondozás:

Informatikai tehetséggondozás: Ég és Föld vonzásában a természet titkai Informatikai tehetséggondozás: Összetett programozási tételek 2 TÁMOP-4.2.3.-12/1/KONV Feladataink egy jelentős csoportjában több bemenő sorozat alapján egy sorozatot

Részletesebben

Objektum Orientált Programozás VII.

Objektum Orientált Programozás VII. Objektum Orientált Programozás VII. Összetett programozási tételek Programozási tételek összeépítése Feladatok ÓE-NIK, 2011 1 Hallgatói Tájékoztató A jelen bemutatóban található adatok, tudnivalók és információk

Részletesebben

Egyszerű programozási tételek

Egyszerű programozási tételek Egyszerű programozási tételek 2. előadás Sergyán Szabolcs sergyan.szabolcs@nik.uni-obuda.hu Óbudai Egyetem Neumann János Informatikai Kar 2011. szeptember 15. Sergyán (OE NIK) AAO 02 2011. szeptember 15.

Részletesebben

9. előadás. Programozás-elmélet. Programozási tételek Elemi prog. Sorozatszámítás Eldöntés Kiválasztás Lin. keresés Megszámolás Maximum.

9. előadás. Programozás-elmélet. Programozási tételek Elemi prog. Sorozatszámítás Eldöntés Kiválasztás Lin. keresés Megszámolás Maximum. Programozási tételek Programozási feladatok megoldásakor a top-down (strukturált) programtervezés esetén három vezérlési szerkezetet használunk: - szekvencia - elágazás - ciklus Eddig megismertük az alábbi

Részletesebben

ELEMI PROGRAMOZÁSI TÉTELEK

ELEMI PROGRAMOZÁSI TÉTELEK ELEMI PROGRAMOZÁSI TÉTELEK 1. FELADATMEGOLDÁS PROGRAMOZÁSI TÉTELEKKEL 1.1 A programozási tétel fogalma A programozási tételek típusalgoritmusok, amelyek alkalmazásával garantáltan helyes megoldást adhatunk

Részletesebben

Programozás I. Egyszerű programozási tételek. Sergyán Szabolcs sergyan.szabolcs@nik.uni-obuda.hu

Programozás I. Egyszerű programozási tételek. Sergyán Szabolcs sergyan.szabolcs@nik.uni-obuda.hu Programozás I. 3. előadás Egyszerű programozási tételek Sergyán Szabolcs sergyan.szabolcs@nik.uni-obuda.hu Óbudai Egyetem Neumann János Informatikai Kar Alkalmazott Informatikai Intézet 2015. szeptember

Részletesebben

Közismereti informatika I. 4. előadás

Közismereti informatika I. 4. előadás Közismereti informatika I. 4. előadás Rendezések Bemenet: N: Egész, X: Tömb(1..N: Egész) Kimenet: X: Tömb(1..N: Egész) Előfeltétel: Utófeltétel: Rendezett(X) és X=permutáció(X ) Az eredmény a bemenet egy

Részletesebben

Informatikai tehetséggondozás:

Informatikai tehetséggondozás: Ég és Föld vonzásában a természet titkai Informatikai tehetséggondozás: Elemi programozási tételek 1 TÁMOP-4.2.3.-12/1/KONV-2012-0018 Feladataink egy jelentős csoportjában egyetlen bemenő sorozat alapján

Részletesebben

Programozási tételek. Jegyzet. Összeállította: Faludi Anita 2012.

Programozási tételek. Jegyzet. Összeállította: Faludi Anita 2012. Programozási tételek Jegyzet Összeállította: Faludi Anita 2012. Tartalomjegyzék Bevezetés... 3 Programozási tételek... 4 I. Elemi programozási tételek... 4 1. Sorozatszámítás (összegzés)... 4 2. Eldöntés...

Részletesebben

Programozás I. Egyszerű programozási tételek. Sergyán Szabolcs

Programozás I. Egyszerű programozási tételek. Sergyán Szabolcs Programozás I. 3. előadás Egyszerű programozási tételek Sergyán Szabolcs sergyan.szabolcs@nik.uni-obuda.hu Óbudai Egyetem Neumann János Informatikai Kar Alkalmazott Informatikai Intézet 2015. szeptember

Részletesebben

Programozási alapismeretek 10. előadás

Programozási alapismeretek 10. előadás Programozási alapismeretek 10. előadás Tartalom Kiválogatás + összegzés Kiválogatás + maximumkiválasztás Maximumkiválasztás + kiválogatás Eldöntés + megszámolás Eldöntés + eldöntés Sorozatszámítás mátrixra

Részletesebben

Tartalom. Programozási alapismeretek. 11. előadás

Tartalom. Programozási alapismeretek. 11. előadás Tartalom Programozási alapismeretek 11. előadás Rendezési feladat specifikáció Egyszerű cserés Minimum-kiválasztásos Buborékos Javított buborékos Beillesztéses Javított beillesztéses Szétosztó Számlálva

Részletesebben

Egyszerű programozási tételek

Egyszerű programozási tételek Egyszerű programozási tételek Sorozatszámítás Eljárás Sorozatszámítás(N, X, S) R R 0 Ciklus i 1-től N-ig R R művelet A[i] A : számokat tartalmazó tömb N : A tömb elemszáma R : Művelet eredménye Eldöntés

Részletesebben

Bevezetés a programozásba I.

Bevezetés a programozásba I. Bevezetés a programozásba I. 3. gyakorlat Tömbök, programozási tételek Surányi Márton PPKE-ITK 2010.09.21. ZH! PlanG-ból papír alapú zárthelyit írunk el reláthatólag október 5-én! Tömbök Tömbök Eddig egy-egy

Részletesebben

Informatikai tehetséggondozás:

Informatikai tehetséggondozás: Ég és Föld vonzásában a természet titkai Informatikai tehetséggondozás: Programozási tételek összeépítése TÁMOP-4.2.3.-12/1/KONV-2012-0018 Gyakran előfordul, hogy programozási tételeket egymás után kell

Részletesebben

Egyszerű programozási tételek

Egyszerű programozási tételek Egyszerű programozási tételek Sorozatszámítás tétele Például az X tömbben kövek súlyát tároljuk. Ha ki kellene számolni az összsúlyt, akkor az S = f(s, X(i)) helyére S = S + X(i) kell írni. Az f0 tartalmazza

Részletesebben

Algoritmizálás, adatmodellezés tanítása 7. előadás

Algoritmizálás, adatmodellezés tanítása 7. előadás Algoritmizálás, adatmodellezés tanítása 7. előadás Oszd meg és uralkodj! Több részfeladatra bontás, amelyek hasonlóan oldhatók meg, lépései: a triviális eset (amikor nincs rekurzív hívás) felosztás (megadjuk

Részletesebben

Algoritmizálás és adatmodellezés tanítása beadandó feladat: Algtan1 tanári beadandó /99 1

Algoritmizálás és adatmodellezés tanítása beadandó feladat: Algtan1 tanári beadandó /99 1 Algoritmizálás és adatmodellezés tanítása beadandó feladat: Algtan1 tanári beadandó /99 1 Készítette: Gipsz Jakab Neptun-azonosító: ABC123 E-mail: gipszjakab@seholse.hu Kurzuskód: IT-13AAT1EG Gyakorlatvezető

Részletesebben

Információk. Ismétlés II. Ismétlés. Ismétlés III. A PROGRAMOZÁS ALAPJAI 2. Készítette: Vénné Meskó Katalin. Algoritmus. Algoritmus ábrázolása

Információk. Ismétlés II. Ismétlés. Ismétlés III. A PROGRAMOZÁS ALAPJAI 2. Készítette: Vénné Meskó Katalin. Algoritmus. Algoritmus ábrázolása 1 Információk 2 A PROGRAMOZÁS ALAPJAI 2. Készítette: Vénné Meskó Katalin Elérhetőség mesko.katalin@tfk.kefo.hu Fogadóóra: szerda 9:50-10:35 Számonkérés időpontok Április 25. 9 00 Május 17. 9 00 Június

Részletesebben

Informatikai tehetséggondozás:

Informatikai tehetséggondozás: Ég és Föld vonzásában a természet titkai Informatikai tehetséggondozás: Rendezések TÁMOP-4.2.3.-12/1/KONV-2012-0018 Az alapfeladat egy N elemű sorozat nagyság szerinti sorba rendezése. A sorozat elemei

Részletesebben

Programozási tételek. PPT 2007/2008 tavasz.

Programozási tételek. PPT 2007/2008 tavasz. Programozási tételek szenasi.sandor@nik.bmf.hu PPT 2007/2008 tavasz http://nik.bmf.hu/ppt 1 Témakörök Strukturált programozás paradigma Alapvető programozási tételek Összetett programozási tételek Programozási

Részletesebben

Informatikai tehetséggondozás:

Informatikai tehetséggondozás: Ég és Föld vonzásában a természet titkai Informatikai tehetséggondozás: Visszalépéses maximumkiválasztás TÁMOP-4.2.3.-12/1/KONV 1. Munkásfelvétel: N állás N jelentkező Egy vállalkozás N különböző állásra

Részletesebben

RENDEZÉSEK, TOVÁBBI PROGRAMOZÁSI TÉTELEK

RENDEZÉSEK, TOVÁBBI PROGRAMOZÁSI TÉTELEK RENDEZÉSEK, TOVÁBBI PROGRAMOZÁSI TÉTELEK 1. EGY SOROZATHOZ EGY SOROZATOT RENDELŐ TÉTELEK 1.1 Rendezések 1.1.1 Kitűzés Adott egy sorozat, és a sorozat elemein értelmezett egy < reláció. Rendezzük a sorozat

Részletesebben

PROGRAMOZÁSI NYELVEK (GYAKORLAT)

PROGRAMOZÁSI NYELVEK (GYAKORLAT) PROGRAMOZÁSI NYELVEK (GYAKORLAT) A következő részben olyan szabványos algoritmusokkal fogunk foglalkozni, amelyek segítségével a későbbiekben sok hétköznapi problémát meg tudunk majd oldani. MUNKAHELYZET-

Részletesebben

Informatikai tehetséggondozás:

Informatikai tehetséggondozás: Ég és Föld vonzásában a természet titkai Informatikai tehetséggondozás: Elemi programozási tételek 2 TÁMOP-4.2.3.-12/1/KONV-2012-0018 Feladataink egy jelentős csoportjában egyetlen bemenő sorozat alapján

Részletesebben

Dokumentáció az 1. feladatsorhoz (egyszerű, rövidített kivitelben)

Dokumentáció az 1. feladatsorhoz (egyszerű, rövidített kivitelben) Dokumentáció az 1. feladatsorhoz (egyszerű, rövidített kivitelben) Felhasználói dokumentáció Feladat: Adjuk meg két N elemű vektor skalárszorzatát! Skalárszorzat : X, Y : N i 1 x i * y i Környezet: IBM

Részletesebben

Programozási alapismeretek 3. előadás

Programozási alapismeretek 3. előadás Programozási alapismeretek 3. előadás Tartalom Ciklusok specifikáció+ algoritmika +kódolás Egy bevezető példa a tömbhöz A tömb Elágazás helyett tömb Konstans tömbök 2/42 Ciklusok Feladat: Határozzuk meg

Részletesebben

Bevezetés a programozásba. 5. Előadás: Tömbök

Bevezetés a programozásba. 5. Előadás: Tömbök Bevezetés a programozásba 5. Előadás: Tömbök ISMÉTLÉS Specifikáció Előfeltétel: milyen körülmények között követelünk helyes működést Utófeltétel: mit várunk a kimenettől, mi az összefüggés a kimenet és

Részletesebben

A 2012/2013 tanévi Országos Középiskolai Tanulmányi Verseny első forduló feladatainak megoldása. INFORMATIKÁBÓL II. (programozás) kategóriában

A 2012/2013 tanévi Országos Középiskolai Tanulmányi Verseny első forduló feladatainak megoldása. INFORMATIKÁBÓL II. (programozás) kategóriában Oktatási Hivatal A 2012/2013 tanévi Országos Középiskolai Tanulmányi Verseny első forduló feladatainak megoldása INFORMATIKÁBÓL II. (programozás) kategóriában Kérjük a tisztelt tanár kollégákat, hogy a

Részletesebben

Felvételi tematika INFORMATIKA

Felvételi tematika INFORMATIKA Felvételi tematika INFORMATIKA 2016 FEJEZETEK 1. Természetes számok feldolgozása számjegyenként. 2. Számsorozatok feldolgozása elemenként. Egydimenziós tömbök. 3. Mátrixok feldolgozása elemenként/soronként/oszloponként.

Részletesebben

Programozási alapismeretek 11. előadás

Programozási alapismeretek 11. előadás Programozási alapismeretek 11. előadás Tartalom Rendezési feladat specifikáció Egyszerű cserés rendezés Minimum-kiválasztásos rendezés Buborékos rendezés Javított buborékos rendezés Beillesztéses rendezés

Részletesebben

Programozás I. Metódusok C#-ban Egyszerű programozási tételek. Sergyán Szabolcs sergyan.szabolcs@nik.uni-obuda.hu

Programozás I. Metódusok C#-ban Egyszerű programozási tételek. Sergyán Szabolcs sergyan.szabolcs@nik.uni-obuda.hu Programozás I. 3. előadás Tömbök a C#-ban Metódusok C#-ban Egyszerű programozási tételek Sergyán Szabolcs sergyan.szabolcs@nik.uni-obuda.hu Óbudai Egyetem Neumann János Informatikai Kar Szoftvertechnológia

Részletesebben

Adatszerkezetek II. 6. előadás

Adatszerkezetek II. 6. előadás Adatszerkezetek II. 6. előadás Feladat: Egy kábelhálózat különböző csatornáin N filmet játszanak. Ismerjük mindegyik film kezdési és végidejét. Egyszerre csak 1 filmet tudunk nézni. Add meg, hogy maximum

Részletesebben

Készítette: Nagy Tibor István Felhasznált irodalom: Kotsis Domokos: OOP diasor Zsakó L., Szlávi P.: Mikrológia 19.

Készítette: Nagy Tibor István Felhasznált irodalom: Kotsis Domokos: OOP diasor Zsakó L., Szlávi P.: Mikrológia 19. Készítette: Nagy Tibor István Felhasznált irodalom: Kotsis Domokos: OOP diasor Zsakó L., Szlávi P.: Mikrológia 19. Programkészítés Megrendelői igények begyűjtése Megoldás megtervezése (algoritmuskészítés)

Részletesebben

Bevezetés a programozásba I 4. gyakorlat. PLanG: Szekvenciális fájlkezelés. Szekvenciális fájlkezelés Fájlok használata

Bevezetés a programozásba I 4. gyakorlat. PLanG: Szekvenciális fájlkezelés. Szekvenciális fájlkezelés Fájlok használata Pázmány Péter Katolikus Egyetem Információs Technológiai Kar Bevezetés a programozásba I 4. gyakorlat PLanG: 2011.10.04. Giachetta Roberto groberto@inf.elte.hu http://people.inf.elte.hu/groberto Fájlok

Részletesebben

Gyakorló feladatok az 1. nagy zárthelyire

Gyakorló feladatok az 1. nagy zárthelyire Gyakorló feladatok az 1. nagy zárthelyire 2012. október 7. 1. Egyszerű, bevezető feladatok 1. Kérjen be a felhasználótól egy sugarat. Írja ki az adott sugarú kör kerületét illetve területét! (Elegendő

Részletesebben

A 2011/2012 tanévi Országos Középiskolai Tanulmányi Verseny első forduló feladatainak megoldása. INFORMATIKÁBÓL II. (programozás) kategóriában

A 2011/2012 tanévi Országos Középiskolai Tanulmányi Verseny első forduló feladatainak megoldása. INFORMATIKÁBÓL II. (programozás) kategóriában Oktatási Hivatal A 2011/2012 tanévi Országos Középiskolai Tanulmányi Verseny első forduló feladatainak megoldása INFORMATIKÁBÓL II. (programozás) kategóriában Kérjük a tisztelt tanár kollégákat, hogy a

Részletesebben

Alkalmazott modul: Programozás. Programozási tételek, rendezések. Programozási tételek Algoritmusok és programozási tételek

Alkalmazott modul: Programozás. Programozási tételek, rendezések. Programozási tételek Algoritmusok és programozási tételek Eötvös Loránd Tudományegyetem Informatikai Kar Alkalmazott modul: Programozás, rendezések 2015 Giachetta Roberto groberto@inf.elte.hu http://people.inf.elte.hu/groberto Algoritmusok és programozási tételek

Részletesebben

Haladó rendezések. PPT 2007/2008 tavasz.

Haladó rendezések. PPT 2007/2008 tavasz. Haladó rendezések szenasi.sandor@nik.bmf.hu PPT 2007/2008 tavasz http://nik.bmf.hu/ppt 1 Témakörök Alapvető összehasonlító rendezések Shell rendezés Kupacrendezés Leszámláló rendezés Radix rendezés Edényrendezés

Részletesebben

Algoritmusok és adatszerkezetek I. 7. előadás

Algoritmusok és adatszerkezetek I. 7. előadás Algoritmusok és adatszerkezetek I. 7. előadás Feladat 1. változat Visszalépéses keresés Egy vállalkozás N különböző állásra keres munkásokat. Pontosan N jelentkező érkezett, ahol minden jelentkező megmondta,

Részletesebben

Informatikai tehetséggondozás:

Informatikai tehetséggondozás: Ég és Föld vonzásában a természet titkai Informatikai tehetséggondozás: Multihalmaz típus TÁMOP-4.2.3.-12/1/KONV Értékhalmaz: az alaphalmaz (amely az Elemtípus és egy darabszám által van meghatározva)

Részletesebben

Rendezések. A rendezési probléma: Bemenet: Kimenet: n számot tartalmazó (a 1,a 2,,a n ) sorozat

Rendezések. A rendezési probléma: Bemenet: Kimenet: n számot tartalmazó (a 1,a 2,,a n ) sorozat 9. Előadás Rendezések A rendezési probléma: Bemenet: n számot tartalmazó (a 1,a 2,,a n ) sorozat Kimenet: a bemenő sorozat olyan (a 1, a 2,,a n ) permutációja, hogy a 1 a 2 a n 2 Rendezések Általánosabban:

Részletesebben

Programozási tételek. Elemi programozási tételek. (Sorozathoz érték rendelése)

Programozási tételek. Elemi programozási tételek. (Sorozathoz érték rendelése) Programozás tételek I. Elem programozás tételek (Sorozathoz érték redelése) Olya algortmusokat tárgyaluk meg, amelyek a programozás sorá redszerese előforduló feladatok megoldására kész választ adak. Ezeket

Részletesebben

Webprogramozás szakkör

Webprogramozás szakkör Webprogramozás szakkör Előadás 5 (2012.04.09) Programozás alapok Eddig amit láttunk: Programozás lépései o Feladat leírása (specifikáció) o Algoritmizálás, tervezés (folyamatábra, pszeudokód) o Programozás

Részletesebben

Adatszerkezetek. Nevezetes algoritmusok (Keresések, rendezések)

Adatszerkezetek. Nevezetes algoritmusok (Keresések, rendezések) Adatszerkezetek Nevezetes algoritmusok (Keresések, rendezések) Keresések A probléma általános megfogalmazása: Adott egy N elemű sorozat, keressük meg azt az elemet (határozzuk meg a helyét a sorozatban),

Részletesebben

Programozási alapismeretek beadandó feladat: ProgAlap beadandó feladatok téma 99. feladat 1

Programozási alapismeretek beadandó feladat: ProgAlap beadandó feladatok téma 99. feladat 1 Programozási alapismeretek beadandó feladat: ProgAlap beadandó feladatok téma 99. feladat 1 Készítette: Gipsz Jakab Neptun-azonosító: A1B2C3 E-mail: gipszjakab@vilaghalo.hu Kurzuskód: IP-08PAED Gyakorlatvezető

Részletesebben

Alkalmazott modul: Programozás. Programozási tételek, rendezések Giachetta Roberto

Alkalmazott modul: Programozás. Programozási tételek, rendezések Giachetta Roberto Eötvös Loránd Tudományegyetem Informatikai Kar Alkalmazott modul: Programozás Programozási tételek, rendezések 2015 Giachetta Roberto groberto@inf.elte.hu http://people.inf.elte.hu/groberto Algoritmusok

Részletesebben

Sorozat érték típusú programozási tételek

Sorozat érték típusú programozási tételek Sorozat érték típusú programozási tételek A soron következő specifikációk és algoritmusok mind olyan típusfeladatokhoz kötődnek, amik igazán sűrűn előfordulhatnak a gyakorlatban. Meg kell keresni valamit,

Részletesebben

Sorozatok I. Brósch Zoltán (Debreceni Egyetem Kossuth Lajos Gyakorló Gimnáziuma)

Sorozatok I. Brósch Zoltán (Debreceni Egyetem Kossuth Lajos Gyakorló Gimnáziuma) Sorozatok I. DEFINÍCIÓ: (Számsorozat) A számsorozat olyan függvény, amelynek értelmezési tartománya a pozitív egész számok halmaza, értékkészlete a valós számok egy részhalmaza. Jelölés: (a n ), {a n }.

Részletesebben

1.félév/1. Programozásmódszertan 1. ZH

1.félév/1. Programozásmódszertan 1. ZH A 1a. feladat: (1+1+1+3)+5 A programozási tételek gyakori kelléke a Halmazfelsorolás predikátum, amely egy sorozatról megállapítja, hogy teljesül-e rá az, hogy elemeinek multiplicitása 1. Adja meg specifikációját

Részletesebben

Első sorozat (2000. május 22. du.) 1. Oldjamegavalós számok halmazán a. cos x + sin2 x cos x. +sinx +sin2x =

Első sorozat (2000. május 22. du.) 1. Oldjamegavalós számok halmazán a. cos x + sin2 x cos x. +sinx +sin2x = 2000 Írásbeli érettségi-felvételi feladatok Első sorozat (2000. május 22. du.) 1. Oldjamegavalós számok halmazán a egyenletet! cos x + sin2 x cos x +sinx +sin2x = 1 cos x (9 pont) 2. Az ABCO háromszög

Részletesebben

ALGORITMUSOK ÉS PROBLÉMAOSZTÁLYOK (1. előadás)

ALGORITMUSOK ÉS PROBLÉMAOSZTÁLYOK (1. előadás) ALGORITMUSOK ÉS PROBLÉMAOSZTÁLYOK (1. előadás) Programozási feladatok megoldásának lépései 1, a feladatok meghatározása -egyértelmű, rövid, tömör, pontos 2, a feladat algoritmusának elkészítése jól definiált

Részletesebben

Programozási segédlet

Programozási segédlet Programozási segédlet Programozási tételek Az alábbiakban leírtam néhány alap algoritmust, amit ismernie kell annak, aki programozásra adja a fejét. A lista korántsem teljes, ám ennyi elég kell legyen

Részletesebben

Pásztor Attila. Algoritmizálás és programozás tankönyv az emeltszintű érettségihez

Pásztor Attila. Algoritmizálás és programozás tankönyv az emeltszintű érettségihez Pásztor Attila Algoritmizálás és programozás tankönyv az emeltszintű érettségihez 8. ELEMI ALGORITMUSOK II...88 8.1. MÁSOLÁS...88 8.2. KIVÁLOGATÁS...89 8.3. SZÉTVÁLOGATÁS...91 8.4. METSZET (KÖZÖS RÉSZ)...93

Részletesebben

MATEMATIKA ÍRÁSBELI VIZSGA 2009. május 5.

MATEMATIKA ÍRÁSBELI VIZSGA 2009. május 5. MATEMATIKA ÍRÁSBELI VIZSGA 2009. május 5. I. rész Fontos tudnivalók A megoldások sorrendje tetszőleges. A feladatok megoldásához szöveges adatok tárolására és megjelenítésére nem alkalmas zsebszámológépet

Részletesebben

Programozási tételek feladatok

Programozási tételek feladatok 2016/11/22 03:56 1/6 Programozási tételek feladatok < Programozási feladatok Programozási tételek feladatok Szerző: Sallai ndrás Copyright Sallai ndrás, 2011 Licenc: NU Free Documentation License 1.3 Web:

Részletesebben

Algoritmizálás, adatmodellezés tanítása 6. előadás

Algoritmizálás, adatmodellezés tanítása 6. előadás Algoritmizálás, adatmodellezés tanítása 6. előadás Tesztelési módszerek statikus tesztelés kódellenőrzés szintaktikus ellenőrzés szemantikus ellenőrzés dinamikus tesztelés fekete doboz módszerek fehér

Részletesebben

Próbaérettségi feladatsor_a NÉV: osztály Elért pont:

Próbaérettségi feladatsor_a NÉV: osztály Elért pont: Próbaérettségi feladatsor_a NÉV: osztály Elért pont: I. rész A feladatsor 1 példából áll, a megoldásokkal maximum 30 pont szerezhető. A kidolgozásra 45 perc fordítható. 1. feladat Egy osztály tanulói a

Részletesebben

Informatikai tehetséggondozás:

Informatikai tehetséggondozás: Ég és Föld vonzásában a természet titkai Informatikai tehetséggondozás: Mohó stratégia 1. TÁMOP-4.2.3.-12/1/KONV Többféle feladat megoldási stratégia létezik. Közülük az egyik legegyszerűbb a mohó stratégia,

Részletesebben

Informatikai tehetséggondozás:

Informatikai tehetséggondozás: Ég és Föld vonzásában a természet titkai Informatikai tehetséggondozás: Visszalépéses keresés korlátozással TÁMOP-4.2.3.-12/1/KONV A visszalépéses keresés (backtrack) a problémamegoldás igen széles területén

Részletesebben

Programozási Módszertan definíciók, stb.

Programozási Módszertan definíciók, stb. Programozási Módszertan definíciók, stb. 1. Bevezetés Egy adat típusát az adat által felvehető lehetséges értékek halmaza (típusérték halmaz, TÉH), és az ezen értelmezett műveletek (típusműveletek) együttesen

Részletesebben

Objektumorientált Programozás VI.

Objektumorientált Programozás VI. Objektumorientált Programozás VI. Tömb emlékeztető Egyszerű programozási tételek Összetett programozási tételek V 1.0 ÓE-NIK, 2011 1 Hallgatói Tájékoztató A jelen bemutatóban található adatok, tudnivalók

Részletesebben

Rekurzív algoritmusok

Rekurzív algoritmusok Rekurzív algoritmusok 11. előadás Sergyán Szabolcs sergyan.szabolcs@nik.uni-obuda.hu Óbudai Egyetem Neumann János Informatikai Kar 2011. november 14. Sergyán (OE NIK) AAO 11 2011. november 14. 1 / 32 Rekurzív

Részletesebben

1. Jelölje meg az összes igaz állítást a következők közül!

1. Jelölje meg az összes igaz állítást a következők közül! 1. Jelölje meg az összes igaz állítást a következők közül! a) A while ciklusban a feltétel teljesülése esetén végrehajtódik a ciklusmag. b) A do while ciklusban a ciklusmag után egy kilépési feltétel van.

Részletesebben

Tartalomjegyzék Algoritmusok - pszeudókód... 1 42

Tartalomjegyzék Algoritmusok - pszeudókód... 1 42 Tartalomjegyzék Algoritmusok - pszeudókód... 1 42 Abszolút érték...1 Hányados ismételt kivonással...1 Legnagyobb közös osztó... 1 2 Páros számok szűrése...2 Palindrom számok...2 Orosz szorzás...3 Minimum

Részletesebben

1/ gyakorlat. Lineáris Programozási feladatok megoldása szimplex módszerrel. Pécsi Tudományegyetem PTI

1/ gyakorlat. Lineáris Programozási feladatok megoldása szimplex módszerrel. Pécsi Tudományegyetem PTI / Operációkutatás. gyakorlat Lineáris Programozási feladatok megoldása szimplex módszerrel Pécsi Tudományegyetem PTI /. Legyen adott az alábbi LP-feladat: x + 4x + x 9 x + x x + x + x 6 x, x, x x + x +

Részletesebben

Web-programozó Web-programozó

Web-programozó Web-programozó Az Országos Képzési Jegyzékről és az Országos Képzési Jegyzékbe történő felvétel és törlés eljárási rendjéről szóló 133/2010. (IV. 22.) Korm. rendelet alapján. Szakképesítés, szakképesítés-elágazás, rész-szakképesítés,

Részletesebben

Bevezetés a programozáshoz I. Feladatok

Bevezetés a programozáshoz I. Feladatok Bevezetés a programozáshoz I. Feladatok 2006. szeptember 15. 1. Alapfogalmak 1.1. példa: Írjuk fel az A B, A C, (A B) C, és A B C halmazok elemeit, ha A = {0, 1}, B = {1, 2, 3}, C = {p, q}! 1.2. példa:

Részletesebben

Rendezések. Sergyán Szabolcs Óbudai Egyetem Neumann János Informatikai Kar október 24.

Rendezések. Sergyán Szabolcs Óbudai Egyetem Neumann János Informatikai Kar október 24. Rendezések 8. előadás Sergyán Szabolcs sergyan.szabolcs@nik.uni-obuda.hu Óbudai Egyetem Neumann János Informatikai Kar 2011. október 24. Sergyán (OE NIK) AAO 08 2011. október 24. 1 / 1 Felhasznált irodalom

Részletesebben

MATEMATIKA ÉRETTSÉGI TÍPUSFELADATOK MEGOLDÁSAI KÖZÉPSZINT Számelmélet

MATEMATIKA ÉRETTSÉGI TÍPUSFELADATOK MEGOLDÁSAI KÖZÉPSZINT Számelmélet MATEMATIKA ÉRETTSÉGI TÍPUSFELADATOK MEGOLDÁSAI KÖZÉPSZINT Számelmélet A szürkített hátterű feladatrészek nem tartoznak az érintett témakörhöz, azonban szolgálhatnak fontos információval az érintett feladatrészek

Részletesebben

1/12. 3. gyakorlat. Lineáris Programozási feladatok megoldása szimplex módszerrel. Pécsi Tudományegyetem PTI

1/12. 3. gyakorlat. Lineáris Programozási feladatok megoldása szimplex módszerrel. Pécsi Tudományegyetem PTI / Operációkutatás. gyakorlat Lineáris Programozási feladatok megoldása szimplex módszerrel Pécsi Tudományegyetem PTI Normál feladatok megoldása szimplex módszerrel / / Normál feladatok megoldása szimplex

Részletesebben

Oktatási Hivatal. A 2014/2015 tanévi Országos Középiskolai Tanulmányi Verseny első fordulójának feladatai. II. (programozás) kategória

Oktatási Hivatal. A 2014/2015 tanévi Országos Középiskolai Tanulmányi Verseny első fordulójának feladatai. II. (programozás) kategória Oktatási Hivatal A 201/2015 tanévi Országos Középiskolai Tanulmányi Verseny első fordulójának feladatai II. (programozás) kategória 1. feladat: Sorminta (3 pont) Fordítsuk meg: a mintából kell kitalálni

Részletesebben

Matematika (alsó tagozat)

Matematika (alsó tagozat) Matematika (alsó tagozat) Az értékelés elvei és eszközei A tanév során az értékelés alapja a tanulók állandó megfigyelése. Folyamatos fejlesztő célzatú szóbeli értékelés visszajelzést ad a tanuló számára

Részletesebben

AAO 3. Csink László 2007

AAO 3. Csink László 2007 AAO 3 Csink László 2007 Algoritmus fogalma - ismétlés Az algoritmus egy eljárás (jóldefiniált utasítások véges halmaza), amelyet valamely feladat megoldására készítünk. A feladat egy adott kezdeti állapotból

Részletesebben

Beregszászi István Programozási példatár

Beregszászi István Programozási példatár Beregszászi István Programozási példatár 2 1. fejezet 1. laboratóriumi munka 1.1. Matematikai kifejezések Írja fel algoritmikus nyelven a megadott kifejezést megfelelő típusú változók segítségével! Figyeljen

Részletesebben

15. tétel. Adatszerkezetek és algoritmusok vizsga Frissült: 2013. január 30.

15. tétel. Adatszerkezetek és algoritmusok vizsga Frissült: 2013. január 30. 15. tétel Adatszerkezetek és algoritmusok vizsga Frissült: 2013. január 30. Edényrendezés Tegyük fel, hogy tudjuk, hogy a bemenő elemek (A[1..n] elemei) egy m elemű U halmazból kerülnek ki, pl. " A[i]-re

Részletesebben

A lineáris programozás 1 A geometriai megoldás

A lineáris programozás 1 A geometriai megoldás A lineáris programozás A geometriai megoldás Készítette: Dr. Ábrahám István A döntési, gazdasági problémák optimalizálásának jelentős részét lineáris programozással oldjuk meg. A módszer lényege: Az adott

Részletesebben

Informatikai tehetséggondozás:

Informatikai tehetséggondozás: Ég és Föld vonzásában a természet titkai Informatikai tehetséggondozás: isszalépéses keresés TÁMOP-4.2.3.-12/1/KON A visszalépéses keresés (backtrack) a problémamegoldás igen széles területén alkalmazható

Részletesebben

Algoritmusok és Adatstruktúrák

Algoritmusok és Adatstruktúrák V2.1 Algoritmusok és Adatstruktúrák I. félév Hernyák Zoltán E másolat nem használható fel szabadon, a készülő jegyzet egy munkapéldánya. A teljes jegyzetről, vagy annak bármely részéről bármely másolat

Részletesebben

REKURZIÓ. Rekurzív: önmagát ismétlő valami (tevékenység, adatszerkezet stb.) Rekurzív függvény: függvény, amely meghívja saját magát.

REKURZIÓ. Rekurzív: önmagát ismétlő valami (tevékenység, adatszerkezet stb.) Rekurzív függvény: függvény, amely meghívja saját magát. 1. A REKURZIÓ FOGALMA REKURZIÓ Rekurzív: önmagát ismétlő valami (tevékenység, adatszerkezet stb.) Rekurzív függvény: függvény, amely meghívja saját magát. 1.1 Bevezető példák: 1.1.1 Faktoriális Nemrekurzív

Részletesebben

az Energetikai Szakközépiskola és Kollégium kisérettségiző diákjai számára

az Energetikai Szakközépiskola és Kollégium kisérettségiző diákjai számára 8. témakör: FÜGGVÉNYEK A feladatok megoldásához használjuk a Négyjegyű függvénytáblázatot! Függvények: 6-30. oldal. Ábrázold a koordinátasíkon azokat a pontokat, amelyek koordinátái kielégítik a következő

Részletesebben

NAGY KRISZTIÁN. Programozás. a Modellező informatikus szakirányon 1. KÖTET. 4. kiadás

NAGY KRISZTIÁN. Programozás. a Modellező informatikus szakirányon 1. KÖTET. 4. kiadás NAGY KRISZTIÁN Programozás a Modellező informatikus szakirányon 1. KÖTET 4. kiadás A jegyzet módosítások nélkül szabadon terjeszthető! A jegyzetet értékesíteni szigorúan tilos! Tartalomjegyzék 0.1 Szimbólum

Részletesebben

KITŰZÖTT FELADATOK A IX. OSZTÁLY SZÁMÁRA

KITŰZÖTT FELADATOK A IX. OSZTÁLY SZÁMÁRA Kitűzött eladatok 15 KITŰZÖTT FELADATOK A IX. OSZTÁLY SZÁMÁRA 1. Bizonyítsd be, hogy nem létezik olyan : R R üggvény, amely teljesítené az alábbi egyenlőségek valamelyikét: a) ( x 1) + (1 x) x, x R; b)

Részletesebben

Algoritmusok - pszeudókód... 1

Algoritmusok - pszeudókód... 1 Tartalomjegyzék Algoritmusok - pszeudókód... 1 Abszolút érték... 1 Hányados ismételt kivonással... 1 Legnagyobb közös osztó... 1 Páros számok szűrése... 2 Palindrom számok... 2 Orosz szorzás... 2 Minimum

Részletesebben

1. MATEMATIKA EMELT SZINTŰ ÍRÁSBELI FELADATSOR

1. MATEMATIKA EMELT SZINTŰ ÍRÁSBELI FELADATSOR 1. MATEMATIKA EMELT SZINTŰ ÍRÁSBELI FELADATSOR A feladatok megoldására 240 perc fordítható, az idő leteltével a munkát be kell fejeznie. A feladatok megoldási sorrendje tetszőleges. A II. részben kitűzött

Részletesebben

Logikai szita (tartalmazás és kizárás elve)

Logikai szita (tartalmazás és kizárás elve) Logikai szita (tartalmazás és kizárás elve) Kombinatorika 5. előadás SZTE Bolyai Intézet Szeged, 2016. március 1. 5. ea. Logikai szita két halmazra 1/4 Középiskolás feladat. Egy 30 fős osztályban a matematikát

Részletesebben

Kalkulus I. Első zárthelyi dolgozat 2014. szeptember 16. MINTA. és q = k 2. k 2. = k 1l 2 k 2 l 1. l 1 l 2. 5 2n 6n + 8

Kalkulus I. Első zárthelyi dolgozat 2014. szeptember 16. MINTA. és q = k 2. k 2. = k 1l 2 k 2 l 1. l 1 l 2. 5 2n 6n + 8 Név, Neptu-kód:.................................................................... 1. Legyeek p, q Q tetszőlegesek. Mutassuk meg, hogy ekkor p q Q. Tegyük fel, hogy p, q Q. Ekkor létezek olya k 1, k 2,

Részletesebben

Készítette: Ernyei Kitti. Halmazok

Készítette: Ernyei Kitti. Halmazok Halmazok Jelölések: A halmazok jele általában nyomtatott nagybetű: A, B, C Az x eleme az A halmaznak: Az x nem eleme az A halmaznak: Az A halmaz az a, b, c elemekből áll: A halmazban egy elemet csak egyszer

Részletesebben

1. tétel. 1. Egy derékszögű háromszög egyik szöge 50, a szög melletti befogója 7 cm. Mekkora a háromszög átfogója? (4 pont)

1. tétel. 1. Egy derékszögű háromszög egyik szöge 50, a szög melletti befogója 7 cm. Mekkora a háromszög átfogója? (4 pont) 1. tétel 1. Egy derékszögű háromszög egyik szöge 50, a szög melletti befogója cm. Mekkora a háromszög átfogója? (4 pont). Adott az ábrán két vektor. Rajzolja meg a b, a b és az a b vektorokat! (6 pont)

Részletesebben

Programozási alapismeretek. 1. előadás. A problémamegoldás lépései. A programkészítés folyamata. Az algoritmus fogalma. Nyelvi szintek.

Programozási alapismeretek. 1. előadás. A problémamegoldás lépései. A programkészítés folyamata. Az algoritmus fogalma. Nyelvi szintek. Tartalom 1. előadás programozás során használt nyelvek A specifikáció Algoritmikus nyelvek A problémamegoldás lépései 3/41 (miből?, mit?) specifikáció (mivel?, hogyan?) adat- + algoritmus-leírás 3. (a

Részletesebben

Szerző. Varga Péter ETR azonosító: VAPQAAI.ELTE Email cím: Név: vp.05@hotmail.com Kurzuskód:

Szerző. Varga Péter ETR azonosító: VAPQAAI.ELTE Email cím: Név: vp.05@hotmail.com Kurzuskód: Szerző Név: Varga Péter ETR azonosító: VAPQAAI.ELTE Email cím: vp.05@hotmail.com Kurzuskód: IP-08PAEG/27 Gyakorlatvezető neve: Kőhegyi János Feladatsorszám: 20 1 Tartalom Szerző... 1 Felhasználói dokumentáció...

Részletesebben

Programozási alapismeretek 1. előadás

Programozási alapismeretek 1. előadás Programozási alapismeretek 1. előadás Tartalom A problémamegoldás lépései programkészítés folyamata A specifikáció Az algoritmus Algoritmikus nyelvek struktogram A kódolás a fejlesztői környezet 2/33 A

Részletesebben

I. Internetes keresési feladatok (ajánlott idő: 20 perc)

I. Internetes keresési feladatok (ajánlott idő: 20 perc) I. Internetes keresési feladatok (ajánlott idő: 20 perc) A talált oldalak internet címét (URL) másold ki egy szöveges dokumentumba és mentsd Csapatnev_internet néven! A konkrét válaszokat ide a papírra

Részletesebben

INFORMATIKAI ALAPISMERETEK

INFORMATIKAI ALAPISMERETEK ÉRETTSÉGI VIZSGA 2005. május 20. INFORMATIKAI ALAPISMERETEK KÖZÉPSZINTŰ ÉRETTSÉGI VIZSGA Az írásbeli vizsga időtartama: 180 perc JAVÍTÁSI-ÉRTÉKELÉSI ÚTMUTATÓ OKTATÁSI MINISZTÉRIUM Megoldási útmutató I.

Részletesebben